Autor Thema: Erreichbarkeit Staging vs. 301 redirect http>https via htaccess  (Gelesen 8120 mal)

Offline fprediger

  • Newbie
  • *
  • Beiträge: 3
    • Profil anzeigen
Hallo zusammen,

über unsere htaccess-Datei werden alle Anfragen auf unsere https-URLs umgeleitet. Hintergrund war die Empfehlung unserer SEO-Agentur, damit Google unsere http und https-URLs nicht als Duplicate-Content wertet und außerdem ein Sicherheitsaspekt unserer Kunden.

Nun haben wir uns für das Staging-Plugin entschieden, können aber nicht auf das Staging-Frontend zugreifen, da die Eingabe "staging.living-delights.de" ebenso auf "https://www.living-delights.de" umgeleitet wird. Ich habe diverse redirect-Befehle recherchiert, letztendlich hat sich nichts geändert oder ich habe den Fehler 500 erhalten.

Ich möchte gerne bis auf die URL "staging.living-delights.de" alle Anfragen auf die entsprechenden SSL-URLs umleiten. Kann mir jemand helfen?  ???

Vielen Dank im Voraus!
Florian

PS: Im Anhang unsere SW-Einstellungen im Staging-Backend

Unsere htaccess-Datei:

ErrorDocument 404 /404.html

<IfModule mod_rewrite.c>
RewriteEngine on
RewriteBase /

RewriteCond %{HTTPS} !=on
RewriteRule ^ https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]

RewriteCond %{REQUEST_URI} ^(.*)//(.*)$
RewriteRule . %1/%2 [R=301,L]

#RewriteBase /shopware/

RewriteRule shopware.dll shopware.php
RewriteRule files/documents/.* engine [NC,L]
RewriteRule backend/media/(.*) media/$1 [NC,L]

RewriteCond %{REQUEST_URI} !(\/(engine|files|templates)\/)
RewriteCond %{REQUEST_URI} !(\/media\/(archive|banner|image|music|pdf|unknown|video)\/)
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*)$ shopware.php [PT,L,QSA]
</IfModule>

# Staging-Rules start
SetEnvIf Host "staging.living-delights.de" ENV=staging

DirectoryIndex index.html
DirectoryIndex index.php
DirectoryIndex shopware.php

# Disables download of configuration
<Files ~ "\.(tpl|yml|ini)$">
    Deny from all
</Files>

# Enable gzip compression
<IfModule mod_deflate.c>
    # disable compression on iconset due to loading problems in google chrome on windows
    SetEnvIfNoCase Request_URI icon-set.css$ no-gzip dont-vary

    AddOutputFilterByType DEFLATE text/html text/xml text/plain text/css text/javascript application/json
</IfModule>

<IfModule mod_expires.c>
<Files ~ "\.(jpe?g|png|gif|css|js)$">
    ExpiresActive on
    ExpiresDefault "access plus 1 month"
    FileETag None
    <IfModule mod_headers.c>
        Header append Cache-Control "public"
        Header unset ETag
    </IfModule>
</Files>
</IfModule>

# Disables auto directory index
<IfModule mod_autoindex.c>
   Options -Indexes
</IfModule>

<IfModule mod_negotiation.c>
    Options -MultiViews
</IfModule>

<IfModule mod_php5.c>
#  php_value memory_limit 128M
#  php_value max_execution_time 120
#  php_value upload_max_filesize 20M
   php_flag phar.readonly off
   php_flag magic_quotes_gpc off
   php_flag session.auto_start off
   php_flag suhosin.session.cryptua off
   php_flag zend.ze1_compatibility_mode off
</IfModule>

#   AddType x-mapp-php5 .php
#   AddHandler x-mapp-php5 .php



Profihost - Joern Ludwig

  • Gast
Versuchen Sie die Regel wie folgt zu erweitern:

RewriteCond %{HTTP_HOST} !^staging.living-delights.de$ [NC]
RewriteCond %{HTTPS} !=on
RewriteRule ^ https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]

Offline fprediger

  • Newbie
  • *
  • Beiträge: 3
    • Profil anzeigen
Habe ich erweitert, wie vorgegeben.

Wenn ich nun in der URL-Zeile bei Google Chrome "staging.living-delights.de" eingebe, macht dieser "https://https//staging.living-delights.de" daraus... Außerdem erhalte ich folgenden Fehlercode laut Google Chrome: DNS_PROBE_FINISHED_NXDOMAIN

Profihost - Joern Ludwig

  • Gast
Ich habe mir soeben Ihre .htaccess angeguckt. Diese sieht aktuell so aus:

RewriteCond %{HTTPS} !=on
RewriteRule ^ https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]

RewriteCond %{HTTP_HOST} !^staging.living-delights.de$ [NC]
RewriteCond %{HTTPS} !=on
RewriteRule ^ https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]

Hier scheint es nun einen doppelten Eintrag zu geben. Bitte etnfernen Sie die erste Condition:

Es sollte dann wie folgt aussehen:

RewriteCond %{HTTP_HOST} !^staging.living-delights.de$ [NC]
RewriteCond %{HTTPS} !=on
RewriteRule ^ https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]

Offline fprediger

  • Newbie
  • *
  • Beiträge: 3
    • Profil anzeigen
Vielen Dank Herr Ludwig! Jetzt funktioniert es  ;D