Autor Thema: Empfohlene PHP 5.6.ini  (Gelesen 13225 mal)

Offline Profihost - Technik

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 2017
    • Profil anzeigen
Empfohlene PHP 5.6.ini
« am: 05.02.2014 15:30 »
Aktivieren Sie bitte zunächst PHP 5.6 auf Ihrem Account. Wie genau Sie dies durchführen können, finden Sie in dem folgenden FAQ Artikel:

PHP 5.6 aktivieren

Erstellen Sie nun eine Datei namens php5.6.ini in Ihrem Heimatverzeichnis mit dem folgenden Inhalt:

upload_max_filesize = 50M
allow_url_fopen     = On
display_errors = Off
magic_quotes_gpc = Off
max_execution_time = 600
memory_limit = 1024M

extension_dir="/usr/local/php_extensions/php5.6/"
extension="apcu.so"

[Zend]
zend_extension=/usr/local/php_extensions/php5.6/ioncube.so
zend_extension=/usr/local/php_extensions/php5.6/opcache.so

opcache.memory_consumption=128
opcache.max_accelerated_files=10000
opcache.max_wasted_percentage=10


wichtiger Hinweis: Wenn Sie ein Medium, Highend oder Business Paket bei uns gebucht haben, müssen Sie die folgende Option in Ihrer ini-Datei verringern, da auf diesen Paketen die RAM Limitierung für die Ausführung von Skripten niedriger ist:

opcache.memory_consumption=64


Durch diese Datei werden alle Komponenten aktiviert, welche Sie für Ihren Shopware Shop benötigen. Unter anderem werden folgende Erweiterungen und Module hierdurch unter PHP 5.6 aktiviert:

- PECL Erweiterung APCu
- IonCube Loader
- Zend OpCache
« Letzte Änderung: 18.10.2017 15:16 von A.Büggeln - Profihost »
Mit freundlichen Grüßen
Ihr ProfiHost Team