Autor Thema: 500: Internal Server Error bei Shop Anbindung mittels Amicron 11  (Gelesen 10093 mal)

Offline hifibau

  • Newbie
  • *
  • Beiträge: 5
    • Profil anzeigen
Hallo zusammen,
habe ein riesiges Problem!!
500: Internal Server Error beim Versuch Artikel upzuloaden

Versuche schon seit einige Zeit meine WaWi Amicron 11 an Shopware 4.2.3 an zu docken.
Artikel aus dem Shop in die WaWi funktioniert, Bestellungen aus dem Shop abholen funktioniert ebenfalls. Wobei hier der Status im Shop wegen einem 500: Internal Server Error nicht geändert wird. Wenn ich jetzt versuche einen Artikel aus der WaWi in Shopware zu exportieren bekomme ich ebenfalls den "500: Internal Server Error"
Eine Anbindung an die Datenbank sollte stehen, würde sonst wohl nicht den korrekten Kategoriebaum des Shops in Amicron angezeigt bekommen und könnte keine Artikel in die WaWi einlesen.

Habe alle Rechte kontrolliert, den Support von Amicron telefonisch kontaktiert (0190 Nr.  :-\ ) Die komplette Schnittstelle noch mal akribisch neu Installiert.........alles ohne Erfolg !!
Ich bekomme den "500: Internal Server Error"

Ich hoffe ich finde über diesen Weg die Lösung meines Problem....währe Euch zu tausend Dank verpflichtet

Gruß
Josef

P. Schreiber - Profihost

  • Gast
Guten Morgen Josef,

um die Ursache des Problems zu finden gibt es verschiedene Herangehensweisen. 

Sie haben die Möglichkeit im Verzeichnis logs/ die Datei error.log auszuwerten, wo PHP Fehler aufgeführt werden.

Des Weiteren könnten Sie über die php5.x.ini die display_errors aktivieren, um eventuell eine genauere Fehlermeldung zu erhalten.
Eine Anleitung hierzu finden Sie in folgendem FAQ Eintrag am Beispiel von PHP 5.4: PHP5.4 - Einstellungen ändern

Eine Dritte Möglichkeit wäre, das error_reporting über die php5.x.ini zu aktivieren. Dafür müsste folgende Zeile hinzugefügt werden:
error_reporting  =  E_ALL
Bitte beachten Sie, dass es nach der Änderung der php5.x.ini bis zu 5 Minuten dauern kann, bis die Änderungen aktiv werden.


Für weitere Fragen stehen wir Ihnen gerne zur Verfügung.




Profihost - Joern Ludwig

  • Gast
Hallo Josef,

was für ein Paket / Server haben Sie denn bei uns?
Gerne können Sie mir Ihre Kundennummer und Domainname per "Forums-Mitteilung" senden.
Dann gucke ich direkt einmal nach.

Offline hifibau

  • Newbie
  • *
  • Beiträge: 5
    • Profil anzeigen
Muss hier noch mal auf mein Problem zurückkommen. Hat jemand eine Idee wo bei dieser Meldung hier das Problem sein könnte.
Diese erscheint in Amicron11 wenn ich versuche einen Artikel in Shopware zu laden.

Zitat
Bei dem Scriptaufruf ist ein Fehler aufgetreten:
<br />
<b>Notice</b>:  Undefined index: user in <b>/hifwfkdw/www.hifi-stecker.de/engine/af11_shopwareV42.php</b> on line <b>13</b><br />
<br />
<b>Fatal error</b>:  Uncaught exception 'Exception' with message 'DateTime::__construct(): It is not safe


Profihost - Joern Ludwig

  • Gast
Das Problem wurde behoben, da die Zeitzone in PHP 5.4 nicht korrekt gesetzt war.
Dies können Sie über eine eigene ini-Datei beheben:

date.timezone = 'Europe/Berlin'
date.default_latitude = 52.5194
date.default_longitude = 13.4067

Wie Sie eine ini-Datei erstellen, finden Sie auf der folgenenden FAQ Seite:

https://www.profihost.com/forum/skriptsprachen-(php-perl-python)/php-5-4-einstellungen-andern/

Offline Artur Nietsch

  • Newbie
  • *
  • Beiträge: 1
    • Profil anzeigen
Hallo Community halle Profihost Team,

ich habe leider das selbe Problem wie oben beschrieben:

nach dem Shopware Update auf die aktuellste Version kommt jetzt bei mir der 500 Server Error.
Gleichfalls habe ich meine PHP.ini auf php5.6.ini anpassen müssen. (wie im Profihost Form beschrieben)

Nun habe ich diese Anweisung befolgt und die php.ini angepasst, leider ohne Erfolg.

date.timezone = 'Europe/Berlin'
date.default_latitude = 52.5194
date.default_longitude = 13.4067
error_reporting  =  E_ALL

upload_max_filesize = 20M
display_errors = Off
magic_quotes_gpc = Off
memory_limit = 400M

extension_dir="/usr/local/php_extensions/php5.6/"
extension="apcu.so"

[Zend]
zend_extension=/usr/local/php_extensions/php5.6/ioncube.so
zend_extension=/usr/local/php_extensions/php5.6/opcache.so

opcache.memory_consumption=128
opcache.max_accelerated_files=10000
opcache.max_wasted_percentage=10

In meiner htaccess habe ich folgende Einträge:


<IfModule mod_php5.c>
#  php_value memory_limit 256M
#  php_value max_execution_time 120
#  php_value upload_max_filesize 20M
   php_flag phar.readonly off
   php_flag magic_quotes_gpc off
   php_flag session.auto_start off
   php_flag suhosin.session.cryptua off
   php_flag zend.ze1_compatibility_mode off
</IfModule>

#   AddType x-mapp-php5 .php
#   AddHandler x-mapp-php5 .php

# Liste der Dateiendungen die als PHP5.6 verarbeitet werden sollen // Hinzugefügt: 16.11.2015
AddHandler php-fastcgi5.6 .php .phtml

Würde mir bitte jemand einen Tipp geben?

Vielen Dank ich hoffe auf Rückmeldung.. auch wenn das Thema so alt ist..

Artur Nietsch
Gartenmaschinen, Holzkohle by Artur Nietsch - www.artur-nietsch.com

Offline F.Niemeyer - Profihost

  • Newbie
  • *
  • Beiträge: 12
    • Profil anzeigen
    • Profihost AG
Guten Morgen Herr Nietsch,

entschuldigen Sie bitte die späte Rückmeldung.

Sofern Ihr Problem noch akut ist, wenden Sie sich bitte telefonisch an unseren technischen Support (0511 5151 81-82).

Vielen Dank!
Mit freundlichen Grüßen
  Frederik Niemeyer
Ihr Profihost Team