Autor Thema: Zend aktivierung nicht möglich  (Gelesen 6363 mal)

Offline -Frank-

  • Newbie
  • *
  • Beiträge: 3
    • Profil anzeigen
Zend aktivierung nicht möglich
« am: 18.02.2015 16:59 »
Hallo ProfiHost Team,

ich würde gerne für den Shop www.mein-fahrrad.de das tabsl Modul installieren.
Dafür ist ja ZendGuard nötig zu aktiveren.
Damit habe ich leider Probleme.

Mein php Version ist: 5.3.28
Ich habe eine php5.3.ini Daten geschrieben mit folgendem Inhalt:
nicht mehr und nicht weniger.


date.timezone = 'Europe/Berlin'
date.default_latitude = 52.5194
date.default_longitude = 13.4067

[Zend]
zend_extension=/usr/local/php_extensions/php5.3/ioncube.so
zend_extension="/usr/local/Zend/lib/ZendGuard/php-5.3.x/ZendGuardLoader.so"
zend_loader.enable=1
zend_loader.disable_licensing=1
zend_extension=/usr/local/php_extensions/php5.3/opcache.so
opcache.memory_consumption=128
opcache.interned_strings_buffer=8
opcache.max_accelerated_files=4000
opcache.revalidate_freq=60
opcache.fast_shutdown=1
opcache.enable_cli=1

Diese Datei habe ich dann per FTP ins Heimatverzeichnis geladen.
Sobald ich diese Datei hochgeladen habe, funktioniert aber der ganze Shop nicht mehr.
In der log steht das keine Verbindung zur SQL Datenbank mehr aufgebaut werden kann.
Lösche ich die Datei, geht es wieder.

Ich habe bestimmt nur einen kleinen Denkfehler drin, wäre über Hilfe aber dankbar.

Mit freundlichen Grüßen,
Frank Nieuwenhuysen

Mirko Lehmann - Profihost

  • Gast
Re: Zend aktivierung nicht möglich
« Antwort #1 am: 19.02.2015 10:49 »
Hallo Herr Nieuwenhuysen!

Bevor Sie die php5.3.ini-Datei hochladen, prüfen Sie bitte Ihre Shopkonfiguration. Die Angabe des Datenbank-Hosts sollte folgendermaßen aussehen:

$this->dbHost = '127.0.0.1:3307';

Anschließend sollte der Shop auch nach der Aktivierung der php5.3.ini funktionieren.

Offline -Frank-

  • Newbie
  • *
  • Beiträge: 3
    • Profil anzeigen
Re: Zend aktivierung nicht möglich
« Antwort #2 am: 19.02.2015 13:02 »
Vielen Dank für die Antwort.

Die IP Adresse habe ich geändert.

Nach dem Hochladen bekomme ich aber wieder einen Fehler:

Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, [no address given] and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

In der error.log steht:
[Thu Feb 19 12:56:24 2015] [error] [client "meine IP"] Premature end of script headers: php5.3

Danke für weitere Hilfe

Offline -Frank-

  • Newbie
  • *
  • Beiträge: 3
    • Profil anzeigen
Re: Zend aktivierung nicht möglich
« Antwort #3 am: 20.02.2015 10:26 »
Fehler gefunden:

mit dieser PHP.ini funktionierte es dann:

; Magic quotes
;

; Magic quotes for incoming GET/POST/Cookie data.
magic_quotes_gpc = Off

; Magic quotes for runtime-generated data, e.g. data from SQL, from exec(), etc.
magic_quotes_runtime = Off

; Use Sybase-style magic quotes (escape ' with '' instead of \').
magic_quotes_sybase = Off

; Kundeneinstellungen
upload_max_filesize = 20M
allow_url_fopen = On
display_errors = Off

; ab hier nichts ändern; ab hier nichts ändern
date.timezone = 'Europe/Berlin'
date.default_latitude = 52.5194
date.default_longitude = 13.4067

extension_dir="/usr/local/php_extensions/php5.3/"
extension="apcu.so"

[Zend]
zend_extension=/usr/local/php_extensions/php5.3/ioncube.so
zend_extension="/usr/local/Zend/lib/ZendGuard/php-5.3.x/ZendGuardLoader.so"
zend_loader.enable=1
zend_loader.disable_licensing=1